cosmedcloud offline
Incident Report for cosmedcloud
Resolved
This incident has been resolved.
Posted May 26, 2020 - 13:16 AEST
Monitoring
Access to cosmedcloud is restoring. Please contact the help desk if you are not able to access cosmedcloud
Posted May 26, 2020 - 12:27 AEST
Identified
We are currently investigating reports of issues accessing cosmedclud
Posted May 26, 2020 - 12:15 AEST
This incident affected: Clinic - Web App, Clinic - iPad App, and Clinic - Website & Online Booking Embeds.