Requests timing out
Incident Report for cosmedcloud
Resolved
The incident has resolved. If you are experiencing issues accessing cosmedcloud please close and re-open cosmedcloud
Posted Jun 26, 2020 - 12:16 AEST
Investigating
We are currently investigating this issue.
Posted Jun 26, 2020 - 10:58 AEST