Performance Degradation
Incident Report for cosmedcloud
Resolved
This incident has been resolved.
Posted Jul 04, 2019 - 16:55 AEST
Monitoring
We are currently mitigating a performance issue.
Posted Jul 04, 2019 - 16:27 AEST
Investigating
We are currently investigating performance issues. We will post an update shortly.
Posted Jul 04, 2019 - 16:16 AEST
This incident affected: Clinic - Web App and Clinic - iPad App.