Mobile app slowness
Incident Report for cosmedcloud
Resolved
This incident has been resolved.
Posted Feb 05, 2021 - 11:04 AEST
Monitoring
The issue has been resolved
Posted Feb 04, 2021 - 10:12 AEST
Investigating
We are investigating reports of mobile app slowness
Posted Feb 04, 2021 - 10:01 AEST