Some desktop features may not work using Google Chrome
Incident Report for cosmedcloud
Resolved
We have deployed a improvement that ensures pop up alerts work on the latest version of Google Chrome.

If you continue to experience issues please ensure you refresh the page.
Posted Jul 26, 2021 - 11:28 AEST
Investigating
Due to a recent Google Chrome update some features on desktops such as cancelling an appointment may not work.

We are currently investigating & developing a fix.

In the interim to mitigate the issue you can use Safari on Mac or Edge on Windows (https://www.microsoft.com/en-us/edge)
Posted Jul 22, 2021 - 12:40 AEST
This incident affected: cosmedcloud Web.