Platform access
Incident Report for cosmedcloud
Resolved
This incident has been resolved.
Posted Oct 14, 2019 - 07:07 AEST
Monitoring
Access issues have been resolved and cosmedcloud is available. We will continue to monitor.
Posted Oct 12, 2019 - 07:41 AEST
Investigating
We are currently investigating reports of not being able to access cosmedcloud
Posted Oct 12, 2019 - 07:30 AEST
This incident affected: Clinic - Web App and Clinic - iPad App.