Medicare - Bulk Bill Processing and Payment Reports Unavailable
Incident Report for cosmedcloud
Resolved
This incident has been resolved.
Posted Aug 20, 2019 - 08:46 AEST
Identified
The Australian Government Department of Human Services has advised that Bulk Bill Processing and Payment Reports are currently unavailable.

We will post an update once we receive one from the Department of Human Services.

Any submitted claims will be queued and sent once processing is online.
Posted Aug 19, 2019 - 11:28 AEST
This incident affected: Features (Medicare Claiming).