Issues calling the helpdesk
Incident Report for cosmedcloud
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 16:36 AEST
Investigating
We are currently investigating reports of issues calling the cosmedcloud helpdesk number and are working with our carrier to fix the issue.

As per our standard support process - please use the cosmedcloud helpdesk & ticket portal for all support issues. Available at http://kb.cosmedcloud.com/
Posted Mar 23, 2020 - 12:43 AEST