eMail sending delayed
Incident Report for cosmedcloud
Resolved
This incident has been resolved.
Posted May 13, 2020 - 08:00 AEST
Identified
eMail marketing campaign sending is delayed as we process a large volume of emails being sent. We are adding additional capacity to clear the backlog.
Posted May 12, 2020 - 15:04 AEST
This incident affected: Third-party Service Providers (Mailgun - Email Sending).