Medicare Claiming unavailable
Incident Report for cosmedcloud
Resolved
Medicare Claiming is back online. Created bulk bill and private invoices during the outage period have been sent to Medicare
Posted Jul 13, 2021 - 14:08 AEST
Identified
Submitting claims to Medicare via cosmedcloud is currently unavailable. Bulk billed invoices and patient rebatable invoices will be queued to be sent to Medicare when the service is available.

We are currently working on a fix.
Posted Jul 12, 2021 - 15:19 AEST
This incident affected: v2 - Web and Clinic - Web App.